osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lmoments3 and scipy (again)


Thank you, Kyle and Dennis.
The developer version from 17 months ago, which I hadn't spotted, has
solved my immediate problem. It would be good to have it mainstreamed to
prevent others having the same problem.
David






















On Thu, 15 Oct 2020 at 09:07, Dennis Lee Bieber <wlfraed at ix.netcom.com>
wrote:

> On Wed, 14 Oct 2020 12:05:33 +1300, David Painter
> <david at dpconsulting.co.nz> declaimed the following:
>
> >I'm aware there have been problems with previous versions of
> >lmoments3 working with scipy -- comb having been replaced in scipy. I
> >thought by using pip to install numpy, scipy, lmoments3 [whence distr] I
> >would get compatible latest versions. I'm using 32-bit Python 3.8.6. I've
> >verified scipy 1.5.2 and lmoments3 1.10.4 are present. But I still get a
>
>         <SNIP>
>
> >What am I doing wrong?
>
>         Well, the snarky answer would be "using SciPy 1.5.2"
>
>
> https://docs.scipy.org/doc/scipy/reference/generated/scipy.special.comb.html
>
> "comb" is now under scipy.special, not scipy.misc. But the real fault
> likely needs to be put on lmoments3, since scipy.misc.comb has been
> deprecated all the way back in scipy 1.0.0!
>
>
> https://docs.scipy.org/doc/scipy-1.2.0/reference/generated/scipy.misc.comb.html
>
> https://pypi.org/project/lmoments3/#history indicates that lmoments3
> hasn't
> been updated in over FIVE years.
>
>         A change was merged into the /development/ branch a year and a
> half ago
> https://github.com/OpenHydrology/lmoments3/tree/develop explicitly for
> this
> situation, but has not gone "mainstream"
>
>
>
> --
>         Wulfraed                 Dennis Lee Bieber         AF6VN
>         wlfraed at ix.netcom.com
> http://wlfraed.microdiversity.freeddns.org/
>
> --
> https://mail.python.org/mailman/listinfo/python-list
>