osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trying to Download PygameZero


I am in a 8 grade coding class at the moment and my teacher asked me to download a script called pgzero. I can not seem to download pgzer or pygame when i try it shoots me a error message:??ERROR: Command errored out with exit status 1:? ? ?command: 'c:\program files\python39\python.exe' -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\thedg\\AppData\\Local\\Temp\\pip-install-g9sb_mr0\\pygame\\setup.py'"'"'; __file__='"'"'C:\\Users\\thedg\\AppData\\Local\\Temp\\pip-install-g9sb_mr0\\pygame\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base 'C:\Users\thedg\AppData\Local\Temp\pip-pip-egg-info-rre7x6r3'? ? ? ? ?cwd: C:\Users\thedg\AppData\Local\Temp\pip-install-g9sb_mr0\pygame\? ? Complete output (17 lines):

? ? WARNING, No "Setup" File Exists, Running "buildconfig/config.py"? ? Using WINDOWS configuration...

? ? Download prebuilts to "prebuilt_downloads" and copy to "./prebuilt-x64"? [Y/n]Traceback (most recent call last):? ? ? File "<string>", line 1, in <module>? ? ? File "C:\Users\thedg\AppData\Local\Temp\pip-install-g9sb_mr0\pygame\setup.py", line 194, in <module>? ? ? ? buildconfig.config.main(AUTO_CONFIG)? ? ? File "C:\Users\thedg\AppData\Local\Temp\pip-install-g9sb_mr0\pygame\buildconfig\config.py", line 210, in main? ? ? ? deps = CFG.main(**kwds)? ? ? File "C:\Users\thedg\AppData\Local\Temp\pip-install-g9sb_mr0\pygame\buildconfig\config_win.py", line 576, in main? ? ? ? and download_win_prebuilt.ask(**download_kwargs):? ? ? File "C:\Users\thedg\AppData\Local\Temp\pip-install-g9sb_mr0\pygame\buildconfig\download_win_prebuilt.py", line 302, in ask? ? ? ? reply = raw_input(? ? EOFError: EOF when reading a line? ? ----------------------------------------ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

Please let me know ASAP how to fix this. Ive spent countless hours trying to fix this, ive tried my changing my Path becasue thats what everyone told me. I have also tried some other means to fix this and non have been sucsussful.
Please Help me,