osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IOError: cannot open resource


On 07/12/2019 16:58, Michael Torrie wrote:
> On 12/7/19 9:48 AM, RobH wrote:
>> On 07/12/2019 16:00, Dan Sommers wrote:
>>> On 12/7/19 9:43 AM, RobH wrote:
>>>> When I run a python project with an oled display on a rasperry pi zero,
>>>> it calls for the Minecraftia.ttf font. I have the said file in
>>>> home/pi/.fonts/
>>>
>>> Do you mean /home/pi/.fonts (with a leading slash, an absolute path
>>> rather than a relative one)?
>>>
>>> Dan
>>
>> Not sure how you mean, but it is just as I typed it, with a forward or
>> leading slash.
>> I have it solved now, with a different font.
> 
> What he means is that according to the stack trace you were asking for:
>         home/pi/.fonts/Minecraftia.ttf
> 
> instead of
>         /home/pi/.fonts/Minecraftia.ttf
> 
> If you cut and paste the traceback then that is what happened.  Likely
> when you tried a different font you added the missing / and all was well.
> 

Yes that is correct, my mistake.