osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

DeprecationWarning in Python 3.6 and 3.7


See this log.

https://travis-ci.org/speedy-net/speedy-net/jobs/514595889

1. In line 172, you *enabled* virtualenv, created by Travis-CI with
old virtualenv library.
2. In the legacy virtualenv, you installed latest virtualenv.

You need to enable virtualenv, *created by* latest virtualenv.
Install latest virtualenv in virtualenv *created by* old virtualenv is
not enough.

?On Wed, Apr 3, 2019 at 11:35 AM ??????? <uri at speedy.net> wrote:?
>
>
> ????
> uri at speedy.net
>
>
> On Wed, Apr 3, 2019 at 2:50 AM Inada Naoki <songofacandy at gmail.com> wrote:
>>
>> The DeprecationWarning is raised for virtualenv's distutils.
>> It is fixed already.  Use latest virtualenv.
>
>
> That's what I wrote. I tried to upgrade to the latest virtualenv (virtualenv==16.4.3) in the tests but the tests still fail in Python 3.6 and 3.7 with the DeprecationWarning. You can see the "pip freeze" before the tests start.
>
> (with Pillow==5.4.1):
> https://travis-ci.org/speedy-net/speedy-net/builds/514284524
>
> (with Pillow==6.0.0):
> https://travis-ci.org/speedy-net/speedy-net/builds/514595887
>
>
>>
>>
>> Links:
>> https://github.com/pypa/virtualenv/pull/1289
>> https://virtualenv.pypa.io/en/latest/changes/#v16-4-0-2019-02-09
>> --
>> Inada Naoki  <songofacandy at gmail.com>



-- 
Inada Naoki  <songofacandy at gmail.com>