osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

python3.7.2 won't compile with SSL support


"Felix Lazaro Carbonell" <felix at epepm.cupet.cu> writes:

> Hello:
>
>  
>
> I'm trying to install python3.7.2 from source in debian9.8  but it doesn't
> compile with SSL.
>
>  
>
> I already installed openssl
>
>  
>
> And ./configure -with-openssl=/usr/include/openssl/ yields:
>
>  
>
> checking for openssl/ssl.h in /usr/include/openssl/... no
>
>  
>
> and ssl.h is certainly in /usr/include/openssl/
>

Looks like it is appending openssl/ssl.h to /usr/include/openssl/ and
failing to find the header.  It's been a long time since I attemped to
build python by hand; perhaps you need to not specify the --with-openssl
argument at all, if the headers are installed in the expected places.

Have you seen https://github.com/pyenv/pyenv?

-- 
regards,
kushal