osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

python package management confusion


On Sunday, 20 January 2019 21:27:53 UTC, Oscar Benjamin  wrote:
> On Sun, 20 Jan 2019 at 21:12, dcs3spp via Python-list
> <python-list at python.org> wrote:
> >
> > Pip 18.1 supports reading pep508 direct urls from install_requires. In future release there are plans to deprecate the --process-dependency-links pip install option:
> > - https://github.com/pypa/pip/issues/4187
> > - https://github.com/pypa/pip/pull/4175
> >
> > Will setuptools provide ability to use direct pep508 urls in install_requires in the future also?
> 
> Someone might answer here but if not I suggest asking this on distutils-sig:
> https://www.python.org/community/sigs/current/distutils-sig/
> 
> Also:
> https://github.com/pypa/setuptools/issues
> 
> --
> Oscar

Cheers, thanks for the resource links, will give them a go. Appreciated :)