osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ipython and prompt-toolkit


On 27/09/2018 07:14, Cecil Westerhof wrote:
> For a long time I cannot update prompt-toolkit, because ipython
> requires a version lower as 2. That is why I still use 1.0.15 instead
> of 2.0.4. Any chance that ipython will be updated concerning this
> dependency?
> 

Well this is an interesting coincidence!

I just had a look, and it turns out that the IPython 7.0 branch uses 
prompt_toolkit 2.0 (the change[1] is dated 29 December 2017). IPython 
7.0 was released just a few hours ago, shortly after you sent this mail!

[1] 
https://github.com/ipython/ipython/commit/8e256bd37373f98580ba1ef1d3fcfd7976802238