osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

pip not resolving newer package than required dependency


I have a module with a dependency specifically on pillow>=4.2.1. We are using an internal PyPI that has removed the pillow 4.x series, but it does have 5.2.0. If we try to install pillow>=4.2.1 it doesn't find anything. If we just instruct pip to install pillow, then it will end up installing pillow 5.2.0 just fine. Is there some peculiar versioning rule I'm running into here?