osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Subprocess Startup Error


On 3/6/2018 6:00 PM, Jeremy Jamar St. Julien wrote:
> Whenever I try to open the python shell it says IDLE?s subprocess didn?t make a connection.

You must be referring to IDLE's GUI Shell, not Python's normal console 
text (TUI?) shell or REPL.

IDLE normally runs its GUI in one process and your code in another 
process, connected by a socket.  The message means that the socket 
connection failed.

Everything worked fine yesterday and I haven?t done anything I think 
would cause this problem.

Something has done something somewhere.

Any way to fix this? I?ve tried repairing and redownloading

Start IDLE in a console with python -m idlelib (idlelib.idle on 2.7) and 
you *may* get an exception or other error message that explains the 
situation.  There are 5 to 10 known possible reasons.

What python binary are you running IDLE with?  (It is displayed on the 
first line of output when you start.)  Start normally and look, then 
start in the console and look, to make sure you are running the same 
Python both times.

-- 
Terry Jan Reedy