osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Strange problem with pip2


Cecil Westerhof <Cecil at decebal.nl> writes:

> There are three pip2 packages that should be updated:
>     apsw (3.13.0.post1) - Latest: 3.9.2.post1 [sdist]
>     mysql-utilities (1.6.4) - Latest: 1.4.3 [sdist]
>     pygobject (3.22.0) - Latest: 3.27.4 [sdist]
>
> But the strange thing is that the installed version is newer as the
> new version. And when I try:
>     pip2 install --upgrade apsw
>
> I get:
>     Requirement already up-to-date: apsw in /usr/lib/python2.7/dist-packages

Playing recently with a daily Ubuntu 18.4 preview, I have
seen something similar: I was told that a Python package must
be updated but Python's installation tools reported: current version
already installed.

I have not investigated (thinking it was a fault of the early
Ubuntu version).