osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

urllib3 1.23 breaks API


On 2018-06-06, Cecil Westerhof <Cecil at decebal.nl> wrote:
> I had installed urllib3 1.22 for Python3. I upgraded it to 1.23. This
> broke the requirements for requests 2.18.4:
>     requests 2.18.4 has requirement urllib3<1.23,>=1.21.1, but you'll have urllib3 1.23 which is incompatible
>
> I downgraded to 1.22, but this should not happen I think.

For some reason requests is weirdly specific about which versions
of urllib3 it will accept. The latest version in github allows
urllib3 1.23, but for some reason requests also appears to have
stopped issuing new releases mid last year.