osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

How to determine lowest version of Python 3 to run?


Op 2017-10-05, Ben Finney schreef <ben+python at benfinney.id.au>:
> Christopher Reimer <christopher_reimer at icloud.com> writes:
>
>> How do I determine the lowest version of Python to [declare that my
>> code supports]?
>
> You can determine that by installing all the Python versions you want to
> try, and running your code's unit test suite on each of them.

An easy way to get a bunch of different Python versions is 
to just pull the various Docker containers for them.

https://hub.docker.com/r/_/python/

Then run your unit tests in each of them.

Note that Python 3.3 support officially ended on 2017-09-29,
so at the moment I wouldn't bother to support anything lower than
3.4. That means testing 3.4, 3.5 and 3.6 (and 3.7 prerelease if
you want to be thorough).

Stephan