osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Python subprocess error win 10


On 5/19/2017 10:27 AM, Havalda Andrew wrote:

> I have encountered a problem with Python 3.6 version, when I open IDLE

How did you start IDLE?

> it says: "Subprocess startup error".

There are over 5 possible reasons for this.

 > I am using Windows 10

That is helpful to know.  How did you install python?  What installer, 
what options?

> I tried to reinstall Python and to use the 64-bit and the 32-bit version
> too. Neither of them worked.

If python starts and runs, which it did to display that message, then 
there is no reason to reinstall completely.  A repair might be needed if 
a particular file is bad.

> I also googled my problem but none of those
> solutions helped me.

Since you did not say what did not work, I don't know what not to 
suggest ;-).  Anyway...

Have you added any files to the Python36 directory?  If so, what.

Open a Command Prompt window.  (Type 'com' in the Win 10 search bar 
"Type here to search" and look under apps.)  After the 'path>' prompt, enter

path> python -m idlelib
or
path> py -3 -m idlelib

If you get the same message and click OK, do you see any error messages?

A workaround, hopefully temporary, is to add the -n (no subprocess) 
option for IDLE.

 > python -m idlelib -n

IDLE will execute you code in the same process with IDLE's.  This 
usually works but occasionally there can be a conflict.

-- 
Terry Jan Reedy