osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PYTHON GDAL


On 07/14/2017 03:57 PM, jorge.conrado at cptec.inpe.br wrote:
> 
> 
> Hi,
> 
> I installed the GDAL 2.2.1 using conda. Then I did:
> 
> import gdal
> 
> and I had:
> 
> 
> Traceback (most recent call last):
>    File "<stdin>", line 1, in <module>
>    File "/home/conrado/miniconda2/lib/python2.7/site-packages/gdal.py", 
> line 2, in <module>
>      from osgeo.gdal import deprecation_warn
>    File 
> "/home/conrado/miniconda2/lib/python2.7/site-packages/osgeo/__init__.py", line 
> 21, in <module>
>      _gdal = swig_import_helper()
>    File 
> "/home/conrado/miniconda2/lib/python2.7/site-packages/osgeo/__init__.py", line 
> 17, in swig_import_helper
>      _mod = imp.load_module('_gdal', fp, pathname, description)
> ImportError: libicui18n.so.56: cannot open shared object file: No such 
> file or directory
> 
> 
> then I used the command find:
> 
> find . -name 'libicui18n.so.56' -print
> 
> and I had:
> 
> ./usr/local/lib/python3.6/site-packages/PyQt5/Qt/lib/libicui18n.so.56
> 
> 
> Please, what can I do to put (set) this lib for python2.7 recognize it.


Since you are using conda I *strongly* recommend to use the conda-forge 
channel to install GDAL:

conda install -c conda-forge gdal

https://conda-forge.org/


> 
> 
> Thanks,
> 
> 
> Conrado