osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PyYaml not using Yaml 1.2?


> Getting in to Ansible and back into Python. Ansible uses pyyaml which says
> it parses yaml version 1.1. Is there a reason it doesn't do yaml version
> 1.2?

Nobody's done the work? Note that on the PyPI page:

https://pypi.python.org/pypi/PyYAML

the last release was almost a year ago. That said, 1.2 has been out
for awhile. There is an open ticket, nearly four years old:

https://bitbucket.org/xi/pyyaml/issues/23/support-yaml-12

Perhaps you can help move that forward.

Skip