OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Python-Dev] test_zlib.py suggestion


Open an issue as this will surely get forgotten otherwise, then people can
discuss on the issue how to handle this.

On Wed, 1 Aug 2018 at 08:40 Michael <aixtools at felt.demon.nl> wrote:

> I have a build_bot running (yeah me!), and was surprised to see
> test_zlib fail on AIX.
>
> There is not an issue with test_zlib, but I do have a suggestion.
>
> I was getting an error with test_flushes(). On python2-2.7.15 the test
> passes and in python3-3.8 (and earlier I expect) the test fails. The
> difference is the addition of the two modes 'Z_PARTIAL_FLUSH' and 'Z_BLOCK'
>
> sync_opt = ['Z_NO_FLUSH', 'Z_SYNC_FLUSH', 'Z_FULL_FLUSH',
>              'Z_PARTIAL_FLUSH', 'Z_BLOCK']
>
> On default AIX installs zlib is, sadly, still at version 1.2.3 and
> Z_BLOCK was 'improved' in version 1.2.5. And it fails on Z_BLOCK.
>
> My suggestion is to enhance the test_library_version() so that it
> verifies that the minor (or smaller?) number is at least '5'
>
> When I static link python with zlib-1.2.11 then the test_zlib passes all
> sub-tests.
>
> Again, not a python bug - but a suggestion for improving what is tested.
>
> I can open an issue, and with a bit of assistance/interest from others
> I'll even do a PR.
>
> Michael
>
> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> https://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe:
> https://mail.python.org/mailman/options/python-dev/brett%40python.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20180801/fcdb8d8a/attachment.html>