osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Python-Dev] We now have C code coverage!


On 6/23/2018 1:09 PM, Zachary Ware wrote:
> On Sat, Jun 23, 2018 at 11:31 AM, Terry Reedy <tjreedy at udel.edu> wrote:
>> I have suggested that, and before that, the same for buildbots.  The reality
>> is that tkinter, IDLE, or turtle could be disabled on *nix by regressions
>> and the official testing would not notice.
> 
> I'm looking into enabling the GUI tests on some of the CI hosts today,
> not sure how far I'll make it with that.  GUI tests are currently
> enabled on my Gentoo [1] and Windows [2] builders, and have been for a
> couple of years at this point; I'm not sure if any other builders are
> running GUI tests.

I noticed your Gentoo builders running gui tests some years ago.  When I 
re-checked perhaps a year ago, they either were not running or seem to 
have skipped test_idle, maybe the former.

> [1] http://buildbot.python.org/all/#/workers/6
> [2] http://buildbot.python.org/all/#/workers/11

Rechecking now, on Gentoo

test_idle appears and passed on these 3.6 and 3.7 pages
http://buildbot.python.org/all/#/builders/82/builds/414/steps/5/logs/stdio

Neither Firefox nor Edge can find 'test_idle' on these 3.x pages
http://buildbot.python.org/all/#/builders/103/builds/1149/steps/5/logs/stdio
http://buildbot.python.org/all/#/builders/99/builds/1130/steps/4/logs/stdio

test_tk appears on 1130 but not 1149

For your 8.1 bot: test_idle passed for 3.7
http://buildbot.python.org/all/#/builders/133/builds/339/steps/3/logs/stdio

but does is not found on this 3.x page (neither is 'test_tk')
http://buildbot.python.org/all/#/builders/12/builds/991/steps/3/logs/stdio

Both Appveyor and my machine run test_idle when running the full 3.x 
test suite.

-- 
Terry Jan Reedy