osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Python-Dev] Slipping Python 3.5.5rc1 and 3.4.8rc1 because of a Travis CI issue--can someone make Travis CI happy?


I created an issue with more information:
https://bugs.python.org/issue32620

Victor

2018-01-22 11:33 GMT+01:00 Larry Hastings <larry at hastings.org>:
>
>
> I have three PRs for Python 3.5.5rc1:
>
> https://github.com/python/cpython/pull/4656
> https://github.com/python/cpython/pull/5197
> https://github.com/python/cpython/pull/5201
>
> I can't merge them because Travis CI is unhappy.  All three CI tests fail in
> the same way, reporting this error:
>
> The command "pyenv global system 3.5" failed and exited with 1 during .
>
> Since Travis CI is a "required check", Github won't let me merge the PR.
> Yes I could manually merge the patches by hand but I'm hoping it doesn't
> come to that.
>
> I'm slipping 3.4.8rc1 because I prefer to do both releases at once.
>
> I'm hoping this problem will be resolved quickly; if we only slip the RCs by
> a day or two I won't slip the final releases (in about two weeks).
>
>
> PLS SND HALP,
>
>
> /arry
>
> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> https://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe:
> https://mail.python.org/mailman/options/python-dev/victor.stinner%40gmail.com
>