[Python-Dev] PEP czar for PEP 3144?
Greg Ewing wrote:
> Guido van Rossum wrote:
>> I personally like having 'iter' in the name (e.g. iterkeys() -- note
>> that we dropped this in Py3k because it's no longer an iterator, it's
>> a dict view now. But I don't want to promote that style for ipaddr.py.
> +1 from me too on having all methods that return iterators
> clearly indicating so. It's an important distinction, and
> it can be very confusing if some methods of an API return
> iterators and others don't with no easy way of remembering
> which is which.
With the prevalence of iterators in Python 3 , the easy way is to
have the API default to iterators, drop 'iter' from the names, and use
'list' in the names to signal the oddball cases where a list is returned