osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openstack] [OpenStack][Keystone] the controller is node listening on port 5000


Hi,

I installed keystone step by step according to the OpenStack Doc
<https://docs.openstack.org/keystone/rocky/install/keystone-install-rdo.html>
but
the http server is not listening on the port 5000!
The only difference is my hostname (address) is "controller.a.b" instead of
"controller".
In verifying part of the document I could do all (like creating a user,
project, ....) but after installing glance, I found out the Glance API is
not running properly and it's because of Keystone is not listening on port
5000!

Here are AUTH variables:

export OS_PROJECT_DOMAIN_NAME=Default
export OS_USER_DOMAIN_NAME=Default
export OS_PROJECT_NAME=admin
export OS_USERNAME=admin
export OS_PASSWORD=XXX
export OS_AUTH_URL=http://controller.a.b:5000/v3
export OS_IDENTITY_API_VERSION=3
export OS_IMAGE_API_VERSION=2

When I try "glance image-list", I got:

"http://controller.a.b:9292/v2/images?limit=20&sort_key=name&sort_dir=asc:
Unable to establish connection"

Here is TCP listening ports:

tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN
    1614/master
tcp        0      0 0.0.0.0:9191            0.0.0.0:*               LISTEN
    961/python2
tcp        0      0 0.0.0.0:25672           0.0.0.0:*               LISTEN
    957/beam.smp
tcp        0      0 192.168.0.31:3306       0.0.0.0:*               LISTEN
    1622/mysqld
tcp        0      0 192.168.0.31:2379       0.0.0.0:*               LISTEN
    963/etcd
tcp        0      0 192.168.0.31:11211      0.0.0.0:*               LISTEN
    952/memcached
tcp        0      0 127.0.0.1:11211         0.0.0.0:*               LISTEN
    952/memcached
tcp        0      0 192.168.0.31:2380       0.0.0.0:*               LISTEN
    963/etcd
tcp        0      0 0.0.0.0:4369            0.0.0.0:*               LISTEN
    1/systemd
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
    953/sshd
tcp6       0      0 ::1:25                  :::*                    LISTEN
    1614/master
tcp6       0      0 :::5000                 :::*                    LISTEN
    960/httpd
tcp6       0      0 :::5672                 :::*                    LISTEN
    957/beam.smp
tcp6       0      0 ::1:11211               :::*                    LISTEN
    952/memcached
tcp6       0      0 :::80                   :::*                    LISTEN
    960/httpd
tcp6       0      0 :::22                   :::*                    LISTEN
    953/sshd

As you can see httpd is listening on port 5000 IPV6, but it's not active
for IPV4!

Here is keystone.log:

2018-11-24 15:55:59.685 17325 INFO keystone.common.wsgi
[req-9fedd505-5d98-4c12-a6ad-967f28c766e7 - - - - -] POST
http://controller.a.b:5000/v3/auth/tokens
2018-11-24 15:56:00.275 17327 INFO keystone.common.wsgi
[req-ca93da87-1d9f-4611-835c-d6972054b8e1 - - - - -] POST
http://controller.a.b:5000/v3/auth/tokens
2018-11-24 15:56:00.929 17328 INFO keystone.common.wsgi
[req-cf8c6af8-342d-4b14-9826-ba27e5f2897a 1b96f6b67f08495092e98a9b60476152
b33579097090499499625154e92724ee - default default] GET
http://controller.a.b:5000/v3/domains/default
2018-11-24 15:56:14.753 17325 INFO keystone.common.wsgi
[req-cca0e4a5-0ef9-40d8-a2f4-56c1f0acafcc 1b96f6b67f08495092e98a9b60476152
b33579097090499499625154e92724ee - default default] POST
http://controller.a.b:5000/v3/users
2018-11-24 15:56:14.773 17325 WARNING py.warnings
[req-cca0e4a5-0ef9-40d8-a2f4-56c1f0acafcc 1b96f6b67f08495092e98a9b60476152
b33579097090499499625154e92724ee - default default]
/usr/lib/python2.7/site-packages/oslo_policy/policy.py:896: UserWarning:
Policy identity:create_user failed scope check. The token used to make the
request was project scoped but the policy requires ['system'] scope. This
behavior may change in the future where using the intended scope is required
  warnings.warn(msg)

Another difference between my system and document is that I use static IP
and here are interface settings:
TYPE="Ethernet"
PROXY_METHOD="none"
BROWSER_ONLY="no"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_FAILURE_FATAL="no"
IPV6_ADDR_GEN_MODE="stable-privacy"
NAME="enp2s0"
UUID="62aa5ce8-64da-41b4-abd3-293fd43584fa"
DEVICE="enp2s0"
ONBOOT="yes"
IPADDR="192.168.0.X"
PREFIX="24"
GATEWAY="192.168.0.1"
DNS1="192.168.0.1"
DNS2="8.8.8.8"
IPV6_PRIVACY="no"


What can be the cause?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20181124/c3a60de6/attachment.html>