osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openstack] Masakari client error


Hi Tushar,

Thanks for linking to that document, I hadn't seen it before and it's very useful. As far as milestones are concerned, I was planning on sticking with Pike. Up until this point I've been using the packages from http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/pike main, when I installed the latest packages from pip, I was ignorant of what I would doing and what would happen. I may switch to queens or rocky, but I would like to upgrade to the latest Ubuntu LTS if I am to do that (bionic only has a repo for rocky but not queens I believe).

----------------------------------------
From: "Patil, Tushar" <Tushar.Patil at nttdata.com>
Sent: 5/16/18 9:03 PM
To: "fungi at yuggoth.org" <fungi at yuggoth.org>, "openstack at lists.openstack.org" <openstack at lists.openstack.org>, "torin.woltjer at granddial.com" <torin.woltjer at granddial.com>
Subject: Re: [Openstack] Masakari client error
Hi Torin,

If you are using stable/pike, then it is recommended to use python-masakariclient version 3.0.1 [1] which requires openstacksdk version 0.9.17.

Are you trying to upgrade your stable/pike environment to the latest rocky-milestone1 (all services including Masakari)?

[1] : https://github.com/openstack/requirements/blob/stable/pike/upper-constraints.txt

Regards,
Tushar Patil

________________________________________
From: Torin Woltjer
Sent: Wednesday, May 16, 2018 10:32:10 PM
To: fungi at yuggoth.org; openstack at lists.openstack.org
Subject: Re: [Openstack] Masakari client error

It looks like pip install actually upgraded my openstacksdk to 0.13 when I installed masakari from pip. Meanwhile the sdk in the 16.04 repository is 0.9.17. I'm wondering now if this might explain why my block storage is also having problems. What is the process for setting up a local environment for separate versions of the SDK (With different services using each?)

Torin Woltjer

Grand Dial Communications - A ZK Tech Inc. Company

616.776.1066 ext. 2006
www.granddial.com

________________________________
From: Jeremy Stanley
Sent: 5/16/18 8:59 AM
To: openstack at lists.openstack.org
Subject: Re: [Openstack] Masakari client error
On 2018-05-16 12:30:47 +0000 (+0000), Torin Woltjer wrote:
[...]
> I am using Pike and not Queens so the openstacksdk version 13 is
> not available in the repository. Should openstacksdk version 0.13
> still work with Pike
[...]

OpenStackSDK strives for backwards-compatibility with even fairly
ancient OpenStack releases, and is not tied to any particular
version of OpenStack services. It should always be safe to run the
latest releases of OpenStackSDK no matter the age of the deployment
with which you intend to communicate.

Note however that the dependencies of OpenStackSDK may conflict with
dependencies of some OpenStack service, so you can't necessarily
expect to be able to co-install them on the same machine without
some means of context separation (virtualenvs, containers, pip
install --local, et cetera).
--
Jeremy Stanley
_______________________________________________
Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Post to : openstack at lists.openstack.org
Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
Disclaimer: This email and any attachments are sent in strictest confidence for the sole use of the addressee and may contain legally privileged,confidential, and proprietary data. If you are not the intended recipient,please advise the sender by replying promptly to this email and then delete and destroy this email and any attachments without any further use, copying or forwarding.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20180517/45ec1f43/attachment.html>