OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openstack] Masakari client error


On 2018-05-16 12:30:47 +0000 (+0000), Torin Woltjer wrote:
[...]
> I am using Pike and not Queens so the openstacksdk version 13 is
> not available in the repository. Should openstacksdk version 0.13
> still work with Pike
[...]

OpenStackSDK strives for backwards-compatibility with even fairly
ancient OpenStack releases, and is not tied to any particular
version of OpenStack services. It should always be safe to run the
latest releases of OpenStackSDK no matter the age of the deployment
with which you intend to communicate.

Note however that the dependencies of OpenStackSDK may conflict with
dependencies of some OpenStack service, so you can't necessarily
expect to be able to co-install them on the same machine without
some means of context separation (virtualenvs, containers, pip
install --local, et cetera).
-- 
Jeremy Stanley
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 963 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20180516/c7142459/attachment.sig>