OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openstack] Not able to use openstack swift using the s3 api plugin...


Hello Shyam,

I did not have so much experience with s3curl but it looks like the problem is caused by client but it seems like the s3token middleware, which is to get authentication with keystone.
So let us check "What authentication are you using", then check "your exisiting configuration". That seems a way to go.

And more, if you could change the reference from https://docs.openstack.org/mitaka/config-reference/object-storage/configure-s3.html,
please consider if you would refer the newest docs at the master of swift3 repository, https://github.com/openstack/swift3.
That is because OpenStack mitaka was approximately 2 years ago and some of the docs looks weird to me. (e.g. recommend swauth by default in the pipeline config)

If you could follow up the Swift upstream, the good news is that swift3 got merged as "s3api" to the Swift upstream repository in recent,
https://github.com/openstack/swift/commit/636b922f3b2882f7dd6c656983d7862b274dcf98.
So you may consider to use the newest version if you prefer to do so.

Best,
Kota


(2018/05/03 16:22), Shyam Prasad N wrote:
> Hi,
> 
> I tried installing the swift3 plugin using the following link:
> https://docs.openstack.org/mitaka/config-reference/object-storage/configure-s3.html
> 
> However, I'm not able to perform the operations:
> # ./s3curl.pl --id=personal -get -- -s -v http://proxy-server:8080
> Unknown option: get
> * Rebuilt URL to: http://proxy-server:8080/
> *   Trying 20.20.20.220...
> * Connected to proxy-server (20.20.20.220) port 8080 (#0)
>> GET / HTTP/1.1
>> Host: proxy-server:8080
>> User-Agent: curl/7.47.0
>> Accept: */*
>> Date: Thu, 03 May 2018 06:07:40 +0000
>> Authorization: AWS
> 4579fb60db3a47069f289d8fd7fa3212:R4zTQJDhPB3G8wLCsNBHaWNjaZQ=
>>
> < HTTP/1.1 500 Internal Server Error
> < x-amz-id-2: txbbe4b8dc26904cbf880e3-005aeaa72c
> < x-amz-request-id: txbbe4b8dc26904cbf880e3-005aeaa72c
> < Content-Type: application/xml
> < X-Trans-Id: txbbe4b8dc26904cbf880e3-005aeaa72c
> < Date: Thu, 03 May 2018 06:07:41 GMT
> < Transfer-Encoding: chunked
> <
> <?xml version='1.0' encoding='UTF-8'?>
> <Error><Code>InternalError</Code><Message>We encountered an internal error.
> Please try
> again.</Message><RequestId>txbbe4b8dc26904cbf880e3-005aeaa72c</RequestId><Reason>&lt;?xml
> version="1.0" encoding="UTF-8"?&gt;&#13;
> &lt;Error&gt;&#13;
>   &lt;Code&gt;InvalidURI&lt;/Code&gt;&#13;
>   &lt;Message&gt;Could not parse the specified URI&lt;/Message&gt;&#13;
> &lt;/Error&gt;&#13;
> * Connection #0 to host proxy-server left intact
> 
> Getting this in the logs...
> May  2 23:07:40 localhost proxy-server: STDERR: (20652) accepted
> ('20.20.20.220', 51030)
> May  2 23:07:41 localhost proxy-server: <?xml version="1.0"
> encoding="UTF-8"?>#015#012<Error>#015#012  <Code>InvalidURI</Code>#015#012
> <Message>Could not parse the specified
> URI</Message>#015#012</Error>#015#012: #012Traceback (most recent call
> last):#012  File "/usr/lib/python2.7/dist-packages/swift3/middleware.py",
> line 81, in __call__#012    resp = self.handle_request(req)#012  File
> "/usr/lib/python2.7/dist-packages/swift3/middleware.py", line 104, in
> handle_request#012    res = getattr(controller, req.method)(req)#012  File
> "/usr/lib/python2.7/dist-packages/swift3/controllers/service.py", line 33,
> in GET#012    resp = req.get_response(self.app, query={'format':
> 'json'})#012  File "/usr/lib/python2.7/dist-packages/swift3/request.py",
> line 686, in get_response#012    headers, body, query)#012  File
> "/usr/lib/python2.7/dist-packages/swift3/request.py", line 665, in
> _get_response#012    raise BadSwiftRequest(err_msg)#012BadSwiftRequest:
> <?xml version="1.0" encoding="UTF-8"?>#015#012<Error>#015#012
> <Code>InvalidURI</Code>#015#012  <Message>Could not parse the specified
> URI</Message>#015#012</Error>#015#012 (txn:
> txbbe4b8dc26904cbf880e3-005aeaa72c)
> May  2 23:07:41 localhost proxy-server: STDERR: 20.20.20.220 - -
> [03/May/2018 06:07:41] "GET / HTTP/1.1" 500 724 0.058274 (txn:
> txbbe4b8dc26904cbf880e3-005aeaa72c)
> 
> Can someone please tell me what's going on?
> Please let me know if some additional data is necessary.
> 
> 
> 
> _______________________________________________
> Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
> Post to     : openstack at lists.openstack.org
> Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
>