OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openstack] Unable to start devstack@n-cpu.service


Thanks a lot Brend, able to run it now :)


On 03/22/2018 04:31 PM, Bernd Bausch wrote:
>
> The rngd service has nothing to do with your problem. Itâ??s described 
> as â??Hardware RNG Entropy Gatherer Daemonâ?? and probably fails because 
> your DevStack runs in a VM, not on hardware.
>
> From what I see, n-cpu fails because Paramiko, the Python library that 
> implements the SSH protocol, succeeds in importing a module named 
> gssapi, but then fails accessing an attribute GSSException in gssapi. 
> This looks like what I see here: 
> https://github.com/paramiko/paramiko/issues/584
>
> It seems to me that you have the wrong Python module gssapi installed 
> on that server. If you donâ??t use Kerberos for authentication, you 
> shouldnâ??t have gssapi at all. When gssapi doesnâ??t exist, Paramiko 
> doesnâ??t even try to access gssapi.GSSException.
>
> Check if you have gssapi, and if so, remove it. Just look for a 
> directory named **gssapi**, and do a *pip uninstall *on the name of 
> that directory.
>
> Bernd.
>
> *From:*sagar.kohli at nic.in [mailto:sagar.kohli at nic.in]
> *Sent:* Thursday, March 22, 2018 6:42 PM
> *To:* Bernd Bausch <berndbausch at gmail.com>; openstack at lists.openstack.org
> *Subject:* Re: [Openstack] Unable to start devstack at n-cpu.service
>
> thanks for the response, as suggested I have tried stable/queens but 
> still getting the same error.
> Few observations
>
>  1. services rngd.service  and devstack at n-cpu.service
>     <mailto:devstack at n-cpu.service> are failed to start.
>  2. processor family - AMD Phenom(tm) II X4 955 Processor
>  3. openvswitch.service is in exited state
>
>
> please find attached
>
>  1. output of*journalctl-n-cpu*
>  2. output of systemctl list-units
>  3. /etc/nova/nova.conf
>  4. /proc/cpuinfo
>
> On 03/22/2018 05:10 AM, Bernd Bausch wrote:
>
>     In my experience, a DevStack cloned from the master branch (which
>     is the default) may occasionally run into inconsistencies such as
>     incompatible library versions. Try a stable branch e.g. git clone
>     ... â??b stable/queens. Or just clone the master again later.
>
>     Your local.conf may also be at the origin of this error.
>
>     The full stack trace with a little bit of context may also be
>     helpful (journalctl â??u devstack at n-cpu). It might contain other
>     errors or warnings that provide a clue.
>
>     Also look for Nova-related errors or warnings in the stack.sh log
>     file.
>
>     Bernd.
>
>     *From:*Sagar Kohli [mailto:sagar.kohli at nic.in]
>     *Sent:* Wednesday, March 21, 2018 6:08 PM
>     *To:* openstack at lists.openstack.org
>     <mailto:openstack at lists.openstack.org>
>     *Subject:* [Openstack] Unable to start devstack at n-cpu.service
>     <mailto:devstack at n-cpu.service>
>
>     I am trying to install devstack on my fresh centos7 machine. All
>     went well.
>     But i am not able to get service devstack at n-cpu.service
>     <mailto:devstack at n-cpu.service> up. following is the output of
>     systemctl status devstack at n-cpu.service
>     <mailto:devstack at n-cpu.service>
>
>         sudo systemctl status devstack at n-cpu.service
>         <mailto:devstack at n-cpu.service>
>         â?? devstack at n-cpu.service <mailto:devstack at n-cpu.service> -
>         Devstack devstack at n-cpu.service <mailto:devstack at n-cpu.service>
>            Loaded: loaded (/etc/systemd/system/devstack at n-cpu.service
>         <mailto:/etc/systemd/system/devstack at n-cpu.service>; enabled;
>         vendor preset: disabled)
>            Active: failed (Result: exit-code) since Wed 2018-03-21
>         15:22:55 EDT; 10h left
>           Process: 4252 ExecStart=/usr/bin/nova-compute --config-file
>         /etc/nova/nova-cpu.conf (code=exited, status=1/FAILURE)
>          Main PID: 4252 (code=exited, status=1/FAILURE)
>
>         Mar 21 15:22:55 localhost.localdomain nova-compute[4252]:
>         ERROR nova     from paramiko.auth_handler import AuthHandler
>         Mar 21 15:22:55 localhost.localdomain nova-compute[4252]:
>         ERROR nova   File
>         "/usr/lib/python2.7/site-packages/paramiko/auth_handler.py",
>         lin...module>
>         Mar 21 15:22:55 localhost.localdomain nova-compute[4252]:
>         ERROR nova     from paramiko.ssh_gss import GSSAuth,
>         GSS_EXCEPTIONS
>         Mar 21 15:22:55 localhost.localdomain nova-compute[4252]:
>         ERROR nova   File
>         "/usr/lib/python2.7/site-packages/paramiko/ssh_gss.py", line
>         54,...module>
>         Mar 21 15:22:55 localhost.localdomain nova-compute[4252]:
>         ERROR nova     GSS_EXCEPTIONS = (gssapi.GSSException,)
>         Mar 21 15:22:55 localhost.localdomain nova-compute[4252]:
>         ERROR nova AttributeError: 'module' object has no attribute
>         'GSSException'
>         Mar 21 15:22:55 localhost.localdomain nova-compute[4252]:
>         ERROR nova
>         Mar 21 15:22:55 localhost.localdomain systemd[1]:
>         devstack at n-cpu.service <mailto:devstack at n-cpu.service>: main
>         process exited, code=exited, status=1/FAILURE
>         Mar 21 15:22:55 localhost.localdomain systemd[1]: Unit
>         devstack at n-cpu.service <mailto:devstack at n-cpu.service> entered
>         failed state.
>         Mar 21 15:22:55 localhost.localdomain systemd[1]:
>         devstack at n-cpu.service <mailto:devstack at n-cpu.service> failed.
>         Hint: Some lines were ellipsized, use -l to show in full.
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20180323/ec1c60fb/attachment.html>