osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Ussuri] [openstack-ansible] [cinder] Can't attach volumes to instances


Hi,
I've deployed OpenStack successfully using openstack-ansible. I use
cinder with LVM backend and can create volumes. However, when I attach
them to an instance, they stay detached (though there's no Error
Message) both using CLI and the Dashboard.

Looking for a solution I read that the cinder logs might contain
relevant information but in Ussuri they don't seem to be present under
/var/log/cinder...

Here's the part of my openstack_user_config.yml regarding Cinder:

```
storage_hosts:
   lvm-storage1:
     ip: 192.168.110.202
     container_vars:
       cinder_backends:
         lvm:
           volume_backend_name: LVM_iSCSI
           volume_driver: cinder.volume.drivers.lvm.LVMVolumeDriver
           volume_group: cinder-volumes
           iscsi_ip_address: 10.0.3.202
         limit_container_types: cinder_volume
```

I've created cinder-volumes with vgcreate before the installation and
all cinder services are up:

# openstack volume service list
+------------------+--------------------------------------+------+---------+-------+----------------------------+
| Binary           | Host                                 | Zone |
Status  | State | Updated At                 |
+------------------+--------------------------------------+------+---------+-------+----------------------------+
| cinder-backup    | bc1bl10                              | nova |
enabled | up    | 2020-10-07T11:24:10.000000 |
| cinder-volume    | bc1bl10 at lvm                          | nova |
enabled | up    | 2020-10-07T11:24:05.000000 |
| cinder-scheduler | infra1-cinder-api-container-1dacc920 | nova |
enabled | up    | 2020-10-07T11:24:05.000000 |
+------------------+--------------------------------------+------+---------+-------+----------------------------+


Thanks in advance!

Kind regards,
Oliver