osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octavia][kolla-ansible][kayobe] - network configuration knowledge gathering


Hi all,

Openstack version is Train
Deployed via Kayobe

I am trying to deploy octavia lbaas but hitting some blockers with regards
to how this should be set up. I think the current issue is the lack of
neutron bridge for the octavia network and I cannot locate how to achieve
this from the documentation.

I have this setup at the moment which I've added another layer 2 network
provisioned to the controller and compute node, for running octavia lbaas:

[Controller node]------------octavia network-----------[Compute node]

However as there's no bridge, the octavia instance cannot connect to it.
The exact error from the logs:

2020-10-05 14:37:34.070 6 INFO
neutron.plugins.ml2.drivers.openvswitch.agent.ovs_neutron_agent [-] Mapping
physical network physnet3 to bridge broct
2020-10-05 14:37:34.070 6 ERROR
neutron.plugins.ml2.drivers.openvswitch.agent.ovs_neutron_agent [-] Bridge
broct for physical network physnet3 does not

Bridge "broct" does exist but it's not a neutron bridge:

[root at juc-kocon1-prd kolla]# brctl show
bridge name     bridge id               STP enabled     interfaces
brext           8000.001a4a16019a       no              eth5
                                                        p-brext-phy
broct           8000.001a4a160173       no              eth6
docker0         8000.0242f5ed2aac       no
[root at juc-kocon1-prd kolla]#


I've been through the docs a few times but I am unable to locate this info.
Most likely the information is there but I am unsure what I need to look
for, hence missing it.

Would any of you be able to help shed light on this or point me to the
documentation?

Thank you

Tony Pearce
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20201005/52d91edd/attachment-0001.html>