osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Idempotency for multiple nics


Hi Monty,

Thanks for the prompt reply. 

Would this change be factored into openstacksdk 0.47.0 or ansible version later than 2.9.9 ?

This is our current ansible version used.

(mypy3) [root at ansnvlonls01 bin]# ansible --version
ansible 2.9.9
  config file = /etc/ansible/ansible.cfg
  configured module search path = ['/root/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /var/lib/awx/venv/mypy3/lib64/python3.6/site-packages/ansible
  executable location = /var/lib/awx/venv/mypy3/bin/ansible
  python version = 3.6.9 (default, Sep 11 2019, 16:40:19) [GCC 4.8.5 20150623 (Red Hat 4.8.5-16)]

Thanks.

Regards,
Sathia

-----Original Message-----
From: Monty Taylor <mordred at inaugust.com> 
Sent: Wednesday, 10 June 2020 10:44 PM
To: Nadarajah, Sathia <Sathia.Nadarajah.2 at team.telstra.com>
Cc: openstack-discuss at lists.openstack.org; kevin at cloudnull.com
Subject: Re: Idempotency for multiple nics
Importance: High

[External Email] This email was sent from outside the organisation â?? be cautious, particularly with links and attachments.

> On Jun 10, 2020, at 1:35 AM, Nadarajah, Sathia <Sathia.Nadarajah.2 at team.telstra.com> wrote:
>
> Hi All,
>
> We are facing the exact issue that is outlined here,
>
> â??When a server is created with multiple nics which holds security groups, module was applying default SG to the server & remove SG on the nics.â??
>
> https://github.com/ansible/ansible/pull/58509
> https://github.com/ansible/ansible/issues/58495
>
> And we are on the following version of openstacksdk
>
> (ansible) [root at ansnvlonls01 bin]# source 
> /var/lib/awx/venv/mypy3/bin/activate
> (mypy3) [root at ansnvlonls01 bin]# pip show openstacksdk
> Name: openstacksdk
> Version: 0.46.0
> Summary: An SDK for building applications to work with OpenStack
> Home-page: https://docs.openstack.org/openstacksdk/
> Author: OpenStack
> Author-email: openstack-discuss at lists.openstack.org
> License: UNKNOWN
> Location: /var/lib/awx/venv/mypy3/lib/python3.6/site-packages
> Requires: netifaces, iso8601, keystoneauth1, os-service-types, PyYAML, 
> cryptography, six, requestsexceptions, decorator, pbr, jmespath, 
> appdirs, munch, jsonpatch, dogpile.cache
>
> When can we expect to have this fix factored into openstacksdk ?
>

It isnâ??t really an openstacksdk issue, itâ??s an issue the ansible modules. Iâ??ve submitted this:

https://review.opendev.org/734810

to the ansible-collections-openstack repo.

> Thanks.
>
> Regards,
>
> Sathia Nadarajah
> Security and Enterprise Engineering CH2 Networks and IT, Telstra 
> <image001.png> P  â?? 0386946619
> M   0437302281
> E  â?? Sathia.Nadarajah.2 at team.telstra.com
> W   www.telstra.com