osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[requirements][mistral][amqp] Failing “docs” job due to the upper constraint conflict for amqp


Hi,

We have a failing â??docsâ?? ([1]) CI job that fails because it implicitly brings amqp 2.5.2 but this lib is not allowed to be higher than 2.5.1 in the upper-constraings.txt in the requirements project ([2]). We see that thereâ??s the patch [3] generated by the proposal bot that bumps the constraint to 2.5.2 for amqp (among others) but it was given -2.

Please assist on how to address in the best way. Should we bump only amqp version in upper constraints for now?

[1] https://zuul.opendev.org/t/openstack/build/6fe7c7d3e60b40458d2a98f3a293f412/log/job-output.txt#840
[2] https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L258
[3] https://review.opendev.org/#/c/681382

Thanks

Renat Akhmerov
@Nokia
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20191002/2b84ed8b/attachment.html>