osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[requirements][monasca] Request for FFE for monasca-common


On 19-09-24 11:39:53, Witek Bedyk wrote:
> On 9/23/19 8:03 PM, Matthew Thode wrote:
> > On 19-09-23 18:05:19, Witek Bedyk wrote:
> > > Hello Requirements Team,
> > > 
> > > I'm requesting FFE for monasca-common library. The new requested version
> > > 2.16.1 includes critical fix for Confluent Kafka client.
> > > 
> > > The library is used only by Monasca project.
> > > 
> > > https://review.opendev.org/683986
> > > 
> > > Thanks
> > > Witek
> > > 
> > 
> > The main question I have is if you will need to change anything in the
> > consuming projects and re-release them (and since they are all monasca,
> > are you ok with doing that if needed).
> > 
> > +----------------------------------+----------------------------------------------------------+------+-------------------------------------+
> > | Repository                       | Filename                                                 | Line | Text                                |
> > +----------------------------------+----------------------------------------------------------+------+-------------------------------------+
> > | openstack/monasca-agent          | requirements.txt                                         |   29 | monasca-common>=2.7.0 # Apache-2.0  |
> > | openstack/monasca-agent          | setup.cfg                                                |   58 | monasca-common>=1.4.0 # Apache-2.0  |
> > | openstack/monasca-api            | requirements.txt                                         |   24 | monasca-common>=2.7.0 # Apache-2.0  |
> > | openstack/monasca-events-api     | requirements.txt                                         |   18 | monasca-common>=1.4.0 # Apache-2.0  |
> > | openstack/monasca-log-api        | requirements.txt                                         |   16 | monasca-common>=2.7.0 # Apache-2.0  |
> > | openstack/monasca-notification   | requirements.txt                                         |   11 | monasca-common>=2.7.0 # Apache-2.0  |
> > | openstack/monasca-persister      | requirements.txt                                         |    8 | monasca-common>=2.16.0 # Apache-2.0 |
> > | openstack/monasca-tempest-plugin | requirements.txt                                         |   13 | monasca-common>=2.8.0 # Apache-2.0  |
> > | openstack/monasca-transform      | requirements.txt                                         |   10 | monasca-common>=2.7.0 # Apache-2.0  |
> > +----------------------------------+----------------------------------------------------------+------+-------------------------------------+
> > 
> > Once those questions are answered I can (dis)approve.
> > 
> 
> 
> Hi Matthew,
> 
> there is no need to change lower constraints in the consuming projects as
> they work perfectly fine with legacy Kafka client in these versions. Also
> all unit tests for lower-constraints jobs pass.
> 
> Only upper-constraints will have to be updated with the new version to
> install the version with the bugfix for Train.
> 
> Thanks
> Witek
> 

Sounds good then, ffe approved.

-- 
Matthew Thode
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190924/6d3cfbf9/attachment.sig>