osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[requirements] [ironic] FFE for python-ironicclient 3.1.0


Hi all,

we would like to request an exception to release python-ironicclient 3.1.0
from the stable/train branch. The current 3.0.0 release has several issues,
one of them [1] is critical and breaks no-auth mode (used e.g. in bifrost).
I'm also proposing [2] to exclude python-ironicclient 3.0.0 from
requirement.

A release request will be posted once [3] merges. The minor version bump is
because we've made the previously existing implicit oslo.config dependency
explicit [4]. I don't believe the new release will break anyone who is not
broken by 3.0.0 already.

Thanks,
Dmitry

[1] https://storyboard.openstack.org/#!/story/2006600
[2] https://review.opendev.org/#/c/684376/
[3] https://review.opendev.org/#/c/684363/
[4] https://review.opendev.org/#/c/684281/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190924/a2ab4cc6/attachment.html>