osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[sdk][release][requirements] FFE requested for openstacksdk



> On Sep 17, 2019, at 4:31 PM, Matthew Thode <mthode at mthode.org> wrote:
> 
> On 19-09-17 16:15:11, Monty Taylor wrote:
>> Heya,
>> 
>> Weâ??d like to cut an 0.35.1 bugfix release as part of train to grab https://review.opendev.org/#/c/680649/ and https://review.opendev.org/#/c/682454/. The first is landed and is in support of the Ironic Nova driver. The second is making its way through the gate right now and is in support of OSC v4.
>> 
> 
> Seems like a larger change than just those two patches if releasing from
> master (as there is no train branch).  What possible projects could this
> require a re-release for?  Below is a table showing what's running with
> a dependency on openstacksdk now

Yes - I think itâ??ll need to be a 0.36.0. We looked at it and nothing should be breaking â?¦ and we havenâ??t cut a stable/train yet. So I think it should just be a constraints bump for folks.

> +--------------------------------------------------+----------------------------------------------------------+------+----------------------------------------------------------------------------+
> | Repository                                       | Filename                                                 | Line | Text                                                                       |
> +--------------------------------------------------+----------------------------------------------------------+------+----------------------------------------------------------------------------+
> | openstack/heat                                   | requirements.txt                                         |   15 | openstacksdk>=0.11.2 # Apache-2.0                                          |
> | openstack/ironic                                 | requirements.txt                                         |   50 | openstacksdk>=0.31.2 # Apache-2.0                                          |
> | openstack/ironic-inspector                       | requirements.txt                                         |   20 | openstacksdk>=0.30.0 # Apache-2.0                                          |
> | openstack/kuryr-kubernetes                       | requirements.txt                                         |   12 | openstacksdk>=0.13.0  # Apache-2.0                                         |
> | openstack/masakari-dashboard                     | requirements.txt                                         |   14 | openstacksdk>=0.26.0                                                       |
> | openstack/masakari-monitors                      | requirements.txt                                         |    7 | openstacksdk>=0.13.0 # Apache-2.0                                          |
> | openstack/metalsmith                             | requirements.txt                                         |    5 | openstacksdk>=0.29.0 # Apache-2.0                                          |
> | openstack/nova                                   | requirements.txt                                         |   74 | openstacksdk>=0.35.0 # Apache-2.0                                          |
> | openstack/octavia-dashboard                      | requirements.txt                                         |    7 | openstacksdk>=0.24.0 # Apache-2.0                                          |
> | openstack/openstack-ansible                      | requirements.txt                                         |   26 | openstacksdk>=0.14.0 # Apache-2.0                                          |
> | openstack/openstack-ansible-tests                | test-requirements.txt                                    |   44 | openstacksdk>=0.14.0 # Apache-2.0                                          |
> | openstack/os-client-config                       | requirements.txt                                         |    4 | openstacksdk>=0.13.0 # Apache-2.0                                          |
> | openstack/osc-lib                                | requirements.txt                                         |   10 | openstacksdk>=0.15.0 # Apache-2.0                                          |
> | openstack/python-masakariclient                  | requirements.txt                                         |    5 | openstacksdk>=0.13.0 # Apache-2.0                                          |
> | openstack/python-novaclient                      | test-requirements.txt                                    |   16 | openstacksdk>=0.11.2 # Apache-2.0                                          |
> | openstack/python-openstackclient                 | requirements.txt                                         |   10 | openstacksdk>=0.17.0 # Apache-2.0                                          |
> | openstack/python-senlinclient                    | requirements.txt                                         |    9 | openstacksdk>=0.24.0 # Apache-2.0                                          |
> | openstack/python-tempestconf                     | requirements.txt                                         |    9 | openstacksdk>=0.11.3 # Apache-2.0                                          |
> | openstack/qinling                                | runtimes/python2/requirements.txt                        |   10 | openstacksdk>=0.9.19                                                       |
> | openstack/qinling                                | runtimes/python3/requirements.txt                        |   10 | openstacksdk>=0.9.19                                                       |
> | openstack/requirements                           | global-requirements.txt                                  |  434 | openstacksdk  # Apache-2.0                                                 |
> | openstack/requirements                           | openstack_requirements/tests/files/upper-constraints.txt |  365 | openstacksdk===0.9.13                                                      |
> | openstack/senlin                                 | requirements.txt                                         |   14 | openstacksdk>=0.27.0 # Apache-2.0                                          |
> | openstack/senlin-tempest-plugin                  | requirements.txt                                         |    7 | openstacksdk>=0.24.0 # Apache-2.0                                          |
> | openstack/shade                                  | requirements.txt                                         |    6 | # shade depends on os-client-config in addition to openstacksdk so that it |
> | openstack/shade                                  | requirements.txt                                         |    9 | openstacksdk>=0.15.0 # Apache-2.0                                          |
> | openstack/sushy-tools                            | test-requirements.txt                                    |   15 | openstacksdk>=0.11.2  # Apache-2.0                                         |
> | openstack/tenks                                  | ansible/roles/ironic-enrolment/files/requirements.txt    |    4 | openstacksdk>=0.17.2 # Apache                                              |
> | openstack/tenks                                  | ansible/roles/nova-flavors/files/requirements.txt        |    4 | openstacksdk>=0.17.2 # Apache                                              |
> | openstack/tripleo-common-tempest-plugin          | requirements.txt                                         |    7 | openstacksdk>=0.11.2 # Apache-2.0                                          |
> | openstack/upstream-institute-virtual-environment | elements/upstream-training/static/tmp/requirements.txt   |  161 | openstacksdk==0.24.0                                                       |
> | x/bilean                                         | requirements.txt                                         |   10 | openstacksdk>=0.7.4 # Apache-2.0                                           |
> | x/flame                                          | requirements.txt                                         |    6 | openstacksdk==0.17.2                                                       |
> | x/monitorstack                                   | requirements.txt                                         |    4 | openstacksdk>=0.9.14                                                       |
> | x/osops-tools-contrib                            | ansible_requirements.txt                                 |   29 | openstacksdk==0.9.8                                                        |
> | zuul/nodepool                                    | requirements.txt                                         |    9 | # openstacksdk before 0.27.0 is TaskManager based                          |
> | zuul/nodepool                                    | requirements.txt                                         |   12 | openstacksdk>=0.27.0,!=0.28.0,!=0.29.0,!=0.30.0,!=0.31.0,!=0.31.1,!=0.31.2 |
> | zuul/zuul-jobs                                   | test-requirements.txt                                    |   22 | openstacksdk>=0.17.1                                                       |
> +--------------------------------------------------+----------------------------------------------------------+------+----------------------------------------------------------------------------+
> 
> -- 
> Matthew Thode