osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[requirements] Issues while trying to bump-up ovsdbapp requirement for stable/queens


On 19-09-17 14:42:00, Maciej Jozefczyk wrote:
> Hey,
> 
> with patching global-requirements [0] our change now pass [1].
> 
> [0] https://review.opendev.org/#/c/682588/1
> [1] https://review.opendev.org/#/c/681562/4
> 
> Maciej
> 
> On Tue, Sep 17, 2019 at 11:07 AM Maciej Jozefczyk <mjozefcz at redhat.com>
> wrote:
> 
> > Hello,
> >
> > I'm trying to bump-up ovsdbapp requirement in networking-ovn [0] from
> > 0.8.0 [1] to 0.10.4 [2]. Those two are in the same stable/queens release
> > and we need that change to merge some serious performance improvements to
> > stable/queens.
> >
> > Unfortunately the requirements-check jobs fails on this change [3] with:
> >
> > Requirement for package ovsdbapp : Requirement(package=u'ovsdbapp', location='', specifiers='>=0.10.4', markers=u'', comment=u'# Apache-2.0', extras=frozenset([])) does not match openstack/requirements value : set([Requirement(package='ovsdbapp', location='', specifiers='>=0.8.0', markers='', comment='# Apache-2.0', extras=frozenset([]))])
> >
> > The only place where >=0.8.0 is set is global-requirements [4]. Do we need
> > to bump up it also there, even the upper-requirements bot proposal [5] has
> > been merged? It is string match?
> >
> > I proposed a change to bump it in global-requirements [6].
> >
> > Thanks,
> > Maciej
> >
> > [0] https://review.opendev.org/#/c/681562/
> > [1] https://github.com/openstack/ovsdbapp/releases/tag/0.8.0
> > [2] https://github.com/openstack/ovsdbapp/releases/tag/0.10.4
> > [3]
> > https://bb8048f0749367929365-38c02a6f4c2535c3f3f9bfdb5440d261.ssl.cf1.rackcdn.com/681562/3/check/requirements-check/84e1e97/job-output.txt
> > [4]
> > https://github.com/openstack/requirements/blob/stable/queens/global-requirements.txt#L402
> > [5] https://review.opendev.org/#/c/682323
> > [6] https://review.opendev.org/#/c/682588
> >

Changing minimums is not allowed for stable releases (especially an
older release like queens and especially for performance (even if
severe).  I do not see anything preventing you from using a newer
version of ovsdbapp.  You may be able to mask bad versions within the
project as long as the upper-constraints version is not masked (using !=
version specifiers).

-- 
Matthew Thode
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190917/0b556301/attachment.sig>