osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[oslo] Kombu 4.6.4 is breaking devstack with python 3.7


Looks like this was blacklisted in g-r: 
https://opendev.org/openstack/requirements/commit/a81aa355d78054c96568de284a34394e4056097f

I've also tagged this with oslo for visibility to our messaging folks.

On 8/16/19 6:45 PM, Daniel Leaberry wrote:
> I'm not sure if this is the correct place to report it but I'm working 
> on the Cinder Thirdparty CI requirement to move testing to Python 3.7.
> https://wiki.openstack.org/wiki/Cinder/3rdParty-drivers-py3-update
> 
> Unfortunately this commit moving Kombu to 4.6.4 a day ago has broken the 
> devstack setup scripts.
> https://opendev.org/openstack/requirements/commit/b236f0af43259959cb2a0f82880cebbdd0da7f27
> 
> It breaks because (I believe) Eventlet is monkey patching and kombu 
> 4.6.4 interacts badly. See these two bug reports for more details.
> 
> https://github.com/eventlet/eventlet/issues/534
> https://github.com/nameko/nameko/issues/655
> 
> Kombu 4.6.4 now results in this error when running
> 
> /usr/local/bin/nova-manage --config-file /etc/nova/nova.conf api_db sync
> 
> 2019-08-16 22:56:25.446 
> <http://openstack-logs.purestorage.com/PureISCSIDriver-tempest-dsvm-xenial-aio-multipath-chap/4816/logs/devstacklog.txt.gz#_2019-08-16_22_56_25_446> 
> | File "/usr/local/lib/python3.7/dist-packages/eventlet/green/os.py", 
> line 107, in open 2019-08-16 22:56:25.446 
> <http://openstack-logs.purestorage.com/PureISCSIDriver-tempest-dsvm-xenial-aio-multipath-chap/4816/logs/devstacklog.txt.gz#_2019-08-16_22_56_25_446> 
> | fd = __original_open__(file, flags, mode, dir_fd=dir_fd) 2019-08-16 
> 22:56:25.446 
> <http://openstack-logs.purestorage.com/PureISCSIDriver-tempest-dsvm-xenial-aio-multipath-chap/4816/logs/devstacklog.txt.gz#_2019-08-16_22_56_25_446> 
> | TypeError: open: path should be string, bytes or os.PathLike, not 
> _NormalAccessor
> 
> You can see full logs here.
> 
> http://openstack-logs.purestorage.com/PureISCSIDriver-tempest-dsvm-xenial-aio-multipath-chap/4816/logs/devstacklog.txt.gz
> 
> I'm open to any recommendation of a workaround. Downgrading to kombu 
> 4.6.3 apparently works fine but I'm not sure how to do that within an 
> automated devstack run.
> 
> Thanks
> 
>