osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Kombu 4.6.4 is breaking devstack with python 3.7


Hi Daniel.

> Unfortunately this commit moving Kombu to 4.6.4 a day ago has broken
the devstack setup scripts.
>
https://opendev.org/openstack/requirements/commit/b236f0af43259959cb2a0f82880cebbdd0da7f27

<snip>
> TypeError: open: path should be string, bytes or os.PathLike, not
_NormalAccessor

After I saw this go by, nova (at least) started failing all
openstack-tox-py37 runs with the same error.

I was able to recreate the problem locally.

I was also able to resolve it by moving kombu back to 4.6.3.

Clearly we need to blacklist kombu 4.6.4 for the moment. I've proposed
that patch here [1].

Thank you very much for identifying the root of the problem.

efried

[1] https://review.opendev.org/#/c/677070/