osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

neutron-server won't start in OpenStack OVN


Hi everyone,

I try to install OpenStack with OVN enabled. But when trying to start
neutron-server, the service is always inactive (exited)

I try to check neutron-server logs and gets this message:

2019-08-14 05:40:32.649 4223 INFO networking_ovn.ml2.qos_driver [-]
Starting OVNQosDriver
2019-08-14 05:40:32.651 4224 INFO networking_ovn.ovsdb.impl_idl_ovn
[-] Getting OvsdbSbOvnIdl for MaintenanceWorker with retry
2019-08-14 05:40:32.654 4225 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6641: connecting...
2019-08-14 05:40:32.655 4225 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6641: connected
2019-08-14 05:40:32.657 4220 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6642: connecting...
2019-08-14 05:40:32.658 4220 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6642: connected
2019-08-14 05:40:32.660 4225 INFO networking_ovn.ovsdb.impl_idl_ovn
[-] Getting OvsdbSbOvnIdl for AllServicesNeutronWorker with retry
2019-08-14 05:40:32.670 4220 INFO neutron.wsgi [-] (4220) wsgi
starting up on http://0.0.0.0:9696
2019-08-14 05:40:32.692 4225 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6642: connecting...
2019-08-14 05:40:32.692 4225 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6642: connected
2019-08-14 05:40:32.693 4224 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6642: connecting...
2019-08-14 05:40:32.694 4224 INFO ovsdbapp.backend.ovs_idl.vlog [-]
tcp:10.101.101.10:6642: connected
2019-08-14 05:40:32.697 4224 INFO networking_ovn.ml2.qos_driver [-]
Starting OVNQosDriver
2019-08-14 05:40:32.844 4225 INFO oslo_service.service [-] Parent
process has died unexpectedly, exiting
2019-08-14 05:40:32.844 4224 INFO oslo_service.service [-] Parent
process has died unexpectedly, exiting
2019-08-14 05:40:32.844 4222 INFO oslo_service.service [-] Parent
process has died unexpectedly, exiting
2019-08-14 05:40:32.845 4223 INFO oslo_service.service [-] Parent
process has died unexpectedly, exiting
2019-08-14 05:40:32.845 4221 INFO oslo_service.service [-] Parent
process has died unexpectedly, exiting


neutron-server full logs: https://paste.ubuntu.com/p/GHfS38KFCr/
ovsdb-server port is active: https://paste.ubuntu.com/p/MhgNs8SGdX/
neutron.conf and ml2_conf.ini: https://paste.ubuntu.com/p/4J7hTVf5qz/

Does anyone know why this error happens?

Best Regards,
Zufar Dhiyaulhaq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190814/fcf3c232/attachment.html>