osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[kolla-ansible] Failed to complete TASK [keystone: Creating the keystone service and enpoint]


I was intrigued by the error so I tried redeploying but this time on a
non-HA deploy (enable_haproxy=no) and it also error'd on that same TASK (
http://paste.openstack.org/show/755605/ )

- Vlad

á?§

On Wed, Aug 7, 2019 at 3:34 PM vladimir franciz blando <
vladimir.blando at gmail.com> wrote:

> OS: CentOS 7 on Baremetal nodes (3x controller, 1xcompute, 2 bonded 10G
> interfaces)
> Ansible: 2.8.3
> kolla-ansible: 8.0.0
>
> kolla_base_distro: "centos"
> kolla_install_type: "source"  # I also tried "binary"
> openstack_release: "stein"
>
> I already tried redeploying (fresh OS reinstallation) 3 times already and
> kolla-ansible deploy always fails on this TASK (
> http://paste.openstack.org/show/755599/) and won't continue and finish
> the deployment.  And I think the issue is that the admin_url was not
> created (http://paste.openstack.org/show/755600/)  but why? Which task
> failed to not create the admin_url? Kolla-ansible only specified that 1
> task failed. On keystone logs (http://paste.openstack.org/show/755601/)
> it says that the admin endpoint was created.  The 3 keystone containers
> (keystone_fernet, keystone_ssh and keystone) are running without error on
> their logs though.
>
> - Vlad
>
>
> á?§
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190807/303fc3f5/attachment.html>