osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdo] [packstack] failing to setup Stein with Openvswitch/VXLAN networking


Thanks Alfredo. Yes, a single eth0:

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
group default qlen 1000
...
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast 
state UP group default qlen 1000
     link/ether 52:54:00:dd:2c:f3 brd ff:ff:ff:ff:ff:ff
     inet 192.168.1.202/24 brd 192.168.1.255 scope global eth0
        valid_lft forever preferred_lft forever
     inet6 240d:1a:3c5:3d00:5054:ff:fedd:2cf3/64 scope global mngtmpaddr 
dynamic
        valid_lft 10790sec preferred_lft 10790sec
     inet6 fe80::5054:ff:fedd:2cf3/64 scope link
        valid_lft forever preferred_lft forever

and ifcfg-eth0 is unchanged since installation (perhaps I should clean 
it up a little; could IPv6 be causing problems?):

$ cat /etc/sysconfig/network-scripts/ifcfg-eth0
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=eth0
UUID=75c26b23-f3fb-4d3f-a473-5354075d5a25
DEVICE=eth0
ONBOOT=yes
IPADDR=192.168.1.202
PREFIX=24
GATEWAY=192.168.1.1
DNS1=192.168.1.16
DNS2=1.1.1.1
DOMAIN=home
IPV6_PRIVACY=no

More info: This is a VM running /CentOS 7.6.1810 /on a Fedora KVM host. 
eth0 is bridged. I did disable and stop network manager and firewalld on 
the guest.

Bernd.

On 7/31/2019 10:13 PM, Alfredo Moralejo Alonso wrote:
> Hi,
>
> So, IIUC, your server has a single NIC, eth0, right?
>
> Could you provide the configuration file for eth0 before running 
> packstack?, i guess you are using ifcfg files?
>
> Best regards,
>
> Alfredo
>
>
> On Wed, Jul 31, 2019 at 2:20 AM Bernd Bausch <berndbausch at gmail.com 
> <mailto:berndbausch at gmail.com>> wrote:
>
>     Trying to set up a Stein cloud with Packstack. I want the
>     Openvswitch mech driver and VXLAN type driver. A few weeks ago,
>     the following invocation was successful:
>
>     |sudo packstack --debug --allinone --default-password pw \
>     --os-neutron-ovs-bridge-interfaces=br-ex:eth0 \
>     --os-neutron-ml2-tenant-network-types=vxlan \
>     --os-neutron-ml2-mechanism-drivers=openvswitch \
>     --os-neutron-ml2-type-drivers=vxlan,flat \
>     --os-neutron-l2-agent=openvswitch \
>     --provision-demo-floatrange=10.1.1.0/24\
>     --provision-demo-allocation-pools
>     '["start=10.1.1.10,end=10.1.1.50"]'\ --os-heat-install=y
>     --os-heat-cfn-install=y|||
>
>     Now, it fails during network setup. My network connection to the
>     Packstack server is severed, and it turns out that its only
>     network interface /eth0 /has no IP address and is down. No bridge
>     exists.
>
>     In the /network.pp.finished /file, I find various /ovs-vsctl
>     /commands including /add-br/, and a command /ifdown eth0 /which
>     fails with exit code 1 (no error message from the /ifdown /command
>     is logged).
>
>     *Can somebody recommend the options required to successfully
>     deploy a Stein cloud based on the Openvswitch and VXLAN drivers?*
>
>     Thanks much,
>
>     Bernd
>
>
>
>     ||
>
>     ||
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190801/172a8478/attachment.html>