osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdo] [packstack] failing to setup Stein with Openvswitch/VXLAN networking


Trying to set up a Stein cloud with Packstack. I want the Openvswitch 
mech driver and VXLAN type driver. A few weeks ago, the following 
invocation was successful:

|sudo packstack --debug --allinone --default-password pw \ 
--os-neutron-ovs-bridge-interfaces=br-ex:eth0 \ 
--os-neutron-ml2-tenant-network-types=vxlan \ 
--os-neutron-ml2-mechanism-drivers=openvswitch \ 
--os-neutron-ml2-type-drivers=vxlan,flat \ 
--os-neutron-l2-agent=openvswitch \ 
--provision-demo-floatrange=10.1.1.0/24\ 
--provision-demo-allocation-pools '["start=10.1.1.10,end=10.1.1.50"]'\ 
--os-heat-install=y --os-heat-cfn-install=y|||

Now, it fails during network setup. My network connection to the 
Packstack server is severed, and it turns out that its only network 
interface /eth0 /has no IP address and is down. No bridge exists.

In the /network.pp.finished /file, I find various /ovs-vsctl /commands 
including /add-br/, and a command /ifdown eth0 /which fails with exit 
code 1 (no error message from the /ifdown /command is logged).

*Can somebody recommend the options required to successfully deploy a 
Stein cloud based on the Openvswitch and VXLAN drivers?*

Thanks much,

Bernd



||

||
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190731/5221a3f9/attachment.html>