osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error: python2-uritemplate conflicts with python2-uri-templates-0.6-5.el7.noarch


Hi Rony,

See inline reply.

On Sat, Jul 27, 2019 at 4:48 PM Md. Farhad Hasan Khan
<rony.khan at brilliant.com.bd> wrote:
>
> Hi,
>
> Please help me how can I fix this.
>
>
>
> Thanks/Rony
>
>
>
>
>
> From: Md. Farhad Hasan Khan [mailto:rony.khan at brilliant.com.bd]
> Sent: Thursday, July 25, 2019 11:48 AM
> To: openstack-discuss at lists.openstack.org
> Subject: Error: python2-uritemplate conflicts with python2-uri-templates-0.6-5.el7.noarch
>
>
>
> Hi,
>
> When I run # yum update and found below conflict:
>
>
>
> --> Processing Conflict: python2-uritemplate-3.0.0-1.el7.noarch conflicts python2-uri-templates
>
> --> Finished Dependency Resolution
>
> Error: python2-uritemplate conflicts with python2-uri-templates-0.6-5.el7.noarch
>
> You could try using --skip-broken to work around the problem
>
> You could try running: rpm -Va --nofiles â??nodigest
>
>
>
> If I remove python2-uri-templates-0.6-5.el7.noarch than below package ask to remove:
>
>
>
> Removing:
>
> python2-uri-templates                   noarch               0.6-5.el7                      @centos-openstack-rocky                20 k
>
> Removing for dependencies:
>
> openstack-cinder                        noarch               1:13.0.5-1.el7                 @centos-openstack-rocky               200 k
>
> python-cinder                           noarch               1:13.0.5-1.el7                 @centos-openstack-rocky                19 M
>
> python2-google-api-client               noarch               1.4.2-4.el7                    @centos-openstack-rocky               305 k
>
>
>
>
>
> please let help me how can I update.
>
>
>From logs(python2-uritemplate-3.0.0-1.el7.noarch) it appears you have
enabled "epel" repository, you can confirm it with yum repolist
command. Mixing epel with OpenStack repos can have such issues.

For now to move ahead i would suggest you disable epel repository
before running "yum update". This should avoid pulling of package
python2-uritemplate and thus conflict with python2-uri-templates)


>
> Thanks/Rony
>
>


Thanks and Regards
Yatin Karel