osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[opendev] git clone fails: "The TLS connection was non-properly terminated"


Looks like some CIs are affected too:
http://logs.openstack.org/88/577388/23/check/grenade-vitrage/13de30a/logs/grenade.sh.txt.gz#_2019-07-23_12_42_37_019
Regards,
Ivan Kolodyazhny,
http://blog.e0ne.info/


On Tue, Jul 23, 2019 at 3:36 PM Ivan Kolodyazhny <e0ne at e0ne.info> wrote:

> Hi all,
>
> Once it works well on my laptop, I'm still facing the same issue on the
> fresh ubuntu18.04-based VM.
>
> Regards,
> Ivan Kolodyazhny,
> http://blog.e0ne.info/
>
>
> On Tue, Jul 23, 2019 at 4:02 AM Bernd Bausch <berndbausch at gmail.com>
> wrote:
>
>> Please ignore; this seems to be a problem on my side.
>> On 7/23/2019 9:09 AM, Bernd Bausch wrote:
>>
>> There seems to be something wrong with the opendev server. Is this a
>> glitch, a daily occurrence (backup?), or a deeper problem?
>>
>> This happens around midnight between July 22 and 23 UTC.
>>
>> $ git clone https://opendev.org/openstack/devstack.git -b stable/stein
>> Cloning into 'devstack'...
>> fatal: unable to access 'https://opendev.org/openstack/devstack.git/':
>> gnutls_handshake() failed: The TLS connection was non-properly terminated.
>>
>> Same result when I try to clone any other random repo. I can get Devstack
>> from Github, but when setting up the cloud, stack.sh wants to clone
>> everything from git.openstack.org, which fails again. I could replace
>> all the hardcoded *git.openstack.org <http://git.openstack.org>* strings
>> with the equivalent *github.com <http://github.com>* URL, but I am not
>> sure if I can trust that all Github repos are up to date.
>>
>> Bernd.
>>
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190723/9bdc15e7/attachment-0001.html>