osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ironic] Using ironic in a devstack environment to deploy OS on bare-metal host.


Greetings,

Typically this sort of error is seen when the IPA ramdisk is unable to
find the drivers for the disk device. Are you trying to build your own
IPA image for your hardware? Are you trying to use tinyipa? Coreos?

If your using a hardware raid controller? have you pre-created a
volume for the OS? Could it be that the hard disk failed?

-Julia

On Mon, Jul 15, 2019 at 2:56 AM Guannan GN2 Sun <sungn2 at lenovo.com> wrote:
>
> Hi team,
>
>
> I met some problem when using ironic in a devstack environment to deploy OS on bare-metal host.
>
> By now I can successfully boot into the tiny os and set ip, also I can ping the ip from my devstack server. However, when the tiny os running some configuration, it will failed after about 5 minutes.
>
> I found some log information in "/var/log/ironic-python-agent.log" in the tiny os that may relate to the problem:
>
>
> "DEBUG oslo_concurrency.processutils [-] u'iscsistart -f' failed. Not Retrying. execute /usr/local/lib/python2.7/site-packages/oslo_concurrency/processutils.py:457"
>
> "DEBUG root [-] No iscsi connection detected. Skipping iscsi. Error: [Errno 2] No such file or directory _check_for_iscsi /usr/local/lib/python2.7/site-packages/ironic_python_agent/hardware.py:107"
>
> "WARNING root [-] The root device was not detected in 27 seconds: DeviceNotFound: Error finding the disk or partition device to deploy the image onto: No suitable device was found for deployment - root device hints were not provided and all found block devices are smaller than 4294967296B."
>
> "WARNING root [-] Can't find field vendor for device usb0 in device class net: IOError: [Errno 2] No such file or directory: '/sys/class/net/usb0/device/vendor'"
>
> "WARNING root [-] Can't find field vendor for device tunl0 in device class net: IOError: [Errno 2] No such file or directory: '/sys/class/net/tunl0/device/vendor'"
>
> "DEBUG root [-] No Mellanox devices found evaluate_hardware_support /usr/local/lib/python2.7/site-packages/ironic_python_agent/hardware_managers/mlnx.py:84"
>
>
> And when it deploy faild and I run command "openstack baremetal node show server-51", it will show following information on 'last_error' field:
>
>
> "Asynchronous exception: Node failed to deploy. Exception: Connection to agent failed: Failed to connect to the agent running on node f8794658-bc69-40cb-9673-be75f78ced21 for invoking command iscsi.start_iscsi_target. Error: ('Connection aborted.', BadStatusLine("''",)) for node"
>
>
> I'm trying to debug, but have not find the root cause, please give me your advice if someone have experience on it. Thank you!
>
>
> Best Regards,
>
> Guannan