osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[k8s][magnum] Kubernetes In Tree Provider Scheduled for Removal in 1.17


After speaking with the SIG-Cloud-Provider leadership this week about the
status of the in-tree OpenStack provider for Kubernetes, weâ??ve decided
that barring a major blocker we will be removing the code during the 1.17
release cycle. This means that any code that depends on the in-tree
provider will not work with the Kubernetes 1.17 release and after.

The in-tree code has been deprecated for over a year now[1], and
SIG-OpenStack has maintained an external provider[2] that has moved
beyond the in-tree code in features and support.

Old releases of Kubernetes will continue to ship with the OpenStack
provider code and work with existing projects. While I would strongly
prefer to just remove the code in the 1.16 release, the logistics just
aren't feasible.[3]

It's time for us to turn our support fully to the external provider and
stop depending on the in-tree code.

Thanks,
Chris Hoge
SIG-OpenStack and SIG-Cloud-Provider co-lead

[1] https://github.com/kubernetes/kubernetes/pull/63524
[2] https://github.com/kubernetes/cloud-provider-openstack
[3] https://github.com/kubernetes/kubernetes/pull/80027