osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fwd: [openstack-community] [openstack-ansible] do I need deploymenthost on same br-mgmt network


Rakesh,

Forwarding this to the discuss list for more attention. Keep in mind OSA
does take some time to run so including at what point you're failing would
be helpful.

Thanks,

Amy (spotz)

---------- Forwarded message ---------
From: rakesh zingade <rakeshzingade at gmail.com>
Date: Wed, Jul 17, 2019 at 3:11 AM
Subject: [openstack-community] [openstack-ansible] do I need deploymenthost
on same br-mgmt network
To: <community at lists.openstack.org>


Hi,

I am pretty new to openstack and openstack ansible. I am trying to install
openstack in our lab. So lab server are on different network (
10.200.105.0/24 [external] and 10.200.75.0/24 [internal-within lab servers])
I suppose to deploy openstack by accessing remote connection and I am on
different network (10.200.104.0/24) in same private lan & can access target
hosts on ssh.

my openstack_user_config.yml as below:

cidr_networks:
  container: 10.200.105.0/24
  storage: 10.200.75.0/24
  tunnel: 10.200.105.0/24

used_ips:
  - "10.200.105.200,10.200.105.201"
  - "10.200.105.1,10.200.105.50"

global_overrides:
  internal_lb_vip_address: 10.200.105.200
  external_lb_vip_address: 10.200.105.200
  management_bridge: "br-mgmt"

  provider_networks:
    - network:
        container_bridge: br-mgmt
        container_interface: eth1
        container_type: veth
        group_binds:
          - all_containers
          - hosts
        ip_from_q: container
        is_container_address: true
        type: raw
    - network:
        container_bridge: br-storage
        container_interface: eth2
        container_mtu: "9000"
        container_type: veth
        group_binds:
          - glance_api
          - cinder_api
          - cinder_volume
          - nova_compute
          - swift_proxy
        ip_from_q: storage
        type: raw
    - network:
        container_bridge: br-vxlan
        container_interface: eth10
        container_mtu: "9000"
        container_type: veth
        group_binds:
          - neutron_linuxbridge_agent
        ip_from_q: tunnel
        net_name: vxlan
        range: "1:1000"
        type: vxlan
    - network:
        container_bridge: br-vlan
        container_interface: eth11
        container_type: veth
        group_binds:
          - neutron_linuxbridge_agent
        net_name: vlan
        range: "101:200,301:400"
        type: vlan
    - network:
        container_bridge: br-vlan
        container_interface: eth12
        container_type: veth
        group_binds:
          - neutron_linuxbridge_agent
        host_bind_override: eth12
        net_name: flat
        type: flat
shared-infra_hosts:
  infra1:
    container_vars:
      container_tech: lxc
    ip: 10.200.105.200

My deployment gets hanged after deploying lxc containers? any clue why this
is happening? is my network is incorrect? do I have to deploy from same
network i.e. 10.200.105.0/24 or 10.200.75.0/24?

please let me know

Thanks,
-- 
Rakesh P. Zingade

_______________________________________________
Community mailing list
Community at lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/community
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190717/164c9d08/attachment-0001.html>