osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cinder issue with DataCore


Hi All,

We are trying to test DataCore storage backend for cinder ( running on 
Queens ). We have everything installed and have the cinder config all 
setup. However whenever we try and start the "cinder-volume" service, we 
get the following error:

2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager File 
"/openstack/venvs/cinder-17.1.2/lib/python2.7/site-packages/cinder/volume/manager.py", 
line 456, in init_host
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager 
self.driver.do_setup(ctxt)
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager   File 
"/openstack/venvs/cinder-17.1.2/lib/python2.7/site-packages/cinder/volume/drivers/datacore/iscsi.py", 
line 83, in do_setup
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager 
super(ISCSIVolumeDriver, self).do_setup(context)
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager   File 
"/openstack/venvs/cinder-17.1.2/lib/python2.7/site-packages/cinder/volume/drivers/datacore/driver.py", 
line 116, in do_setup
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager 
self.configuration.datacore_api_timeout)
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager   File 
"/openstack/venvs/cinder-17.1.2/lib/python2.7/site-packages/cinder/volume/drivers/datacore/api.py", 
line 176, in __init__
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager raise 
datacore_exceptions.DataCoreException(msg)
2019-07-11 12:30:06.977 1909533 ERROR cinder.volume.manager 
DataCoreException: Failed to import websocket-client python module. 
Please, ensure the module is installed.

We have the "websocket-client" installed also:

pip freeze | grep websocket
websocket-client==0.44.0

The datacore libraries also appear to be available in our venvs dirs:

ls 
/openstack/venvs/cinder-17.1.2/lib/python2.7/site-packages/cinder/volume/drivers/datacore
api.py  driver.py  exception.py  fc.py  __init__.py  iscsi.py passwd.py  
utils.py

We are a bit stumped at the moment and wondered if anyone knew what 
might be causing the error? We have managed to get Ceph and SolidFire 
working fine.

Regards,

-- 


Grant Morley
Cloud Lead, Civo Ltd
www.civo.com <https://www.civo.com/>| Signup for an account! 
<https://www.civo.com/signup>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190711/6471f9a1/attachment.html>