osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[TripleO] Using TripleO standalone with ML2/OVS


Hi Slawek,

So from workflow perspective you just need to pass an environment file
with correct set of parameters for ovs(resource_registry and
parameter_defaults) to "openstack tripleo deploy" command in the
end(to override the defaults) with -e <path of environment file>.

In CI multinode ovs jobs are running with environment files containing
ovs specific parameters. For Multinode ovs scenario the environment
file [1]. Standalone ovs work(creation of environment file and CI job)
is WIP by Marios[1]. I just rechecked the job to see where it's stuck
as last failures were unrelated to ovs. @Marios Andreou can share
exact status and @Slawomir Kaplonski you might also help in clearing
it. From job logs of WIP patch you can check command for reference[3].

You can use standalone environment files directly or use them as a
reference and create custom environment files as per your use case.

I have not deployed myself standalone with ovs or any other backend so
can't tell exact parameters but if i try i will start with these
references until someone guides for exact set of parameters someone
uses for standlone ovs deployment. May be someone who have tried it
will post on this mailing list.

[1] https://github.com/openstack/tripleo-heat-templates/blob/master/ci/environments/scenario007-multinode-containers.yaml
[2] https://review.opendev.org/#/q/topic:scenario007+(status:open+OR+status:merged)
[3] http://logs.openstack.org/97/631497/18/check/tripleo-ci-centos-7-scenario007-standalone/a5ee2d3/logs/undercloud/home/zuul/standalone.sh.txt.gz

Regards
Yatin Karel

On Sat, Jul 6, 2019 at 2:33 PM Slawek Kaplonski <skaplons at redhat.com> wrote:
>
> Hi,
>
> I was trying to use TripleO standalone for development work in the way how Emilien described it in [1] and indeed it works quite well. Thx Emilien.
> But now, Iâ??m trying to find out the way how to deploy it with Neutron using ML2/OVS instead of default in TripleO ML2/OVN.
> And I still donâ??t know how to do it :/
> I know itâ??s my fault but maybe someone can help me with this and tell me what exactly options I should change there to deploy it with other Neutron backend?
> Thx in advance for any help.
>
> [1] https://my1.fr/blog/developer-workflow-with-tripleo/
>
> â??
> Slawek Kaplonski
> Senior software engineer
> Red Hat
>
>