osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[requirements] paramiko 2.5.0 causing ImportError: cannot import name py31compat


Hello,

paramiko 2.5.0 was released yesterday [1]. It appears to trigger
failures in the Kayobe molecule job with the following error [2]:

    ImportError: cannot import name py31compat

It's not clear yet why this is happening, since py31compat lives in
setuptools. paramiko 2.5.0 includes changes to paramiko/py3compat.py
which could be related.
For now, we're capping paramiko [3] as it is blocking our gate.

I thought I would share with the list, in case other projects
experience similar errors.

Cheers,
Pierre

[1] https://pypi.org/project/paramiko/#history
[2] http://logs.openstack.org/17/664417/1/check/kayobe-tox-molecule/0370fdd/job-output.txt.gz
[3] https://review.opendev.org/#/c/664533/