osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Release-job-failures] Release of openstack/solum failed


zuul at openstack.org wrote:
> Build failed.
> 
> - release-openstack-python http://logs.openstack.org/19/19a7574237f44807b16c37e0983223ff57340ba3/release/release-openstack-python/769f856/ : POST_FAILURE in 4m 40s
> - announce-release announce-release : SKIPPED
> - propose-update-constraints propose-update-constraints : SKIPPED

Solum release post-job (triggered by stable/pike 5.4.1 tagging) failed 
with the following error:

Ensure twine is installed:
[
     "python3",
     "-m",
     "pip",
     "install",
     "twine!=1.12.0",
     "readme_renderer[md]!=23.0",
     "requests-toolbelt!=0.9.0",
     "--user"
]
Can not perform a '--user' install. User site-packages are not visible 
in this virtualenv.

http://logs.openstack.org/19/19a7574237f44807b16c37e0983223ff57340ba3/release/release-openstack-python/769f856/ara-report/result/163bcef4-584f-4f51-8b40-6c45d4e2282a/

This seems to be a new error hitting us recently (also happened for 
networking-arista, which the release management team does not directly 
handle). It is weird since the job (exact same command) worked in 
subsequent runs:

http://logs.openstack.org/d0/d0d2089455efb6d01a1158bad597f42cf2306c30/release/release-openstack-python/3e92184/ara-report/result/6f1ee497-f721-4f01-80f0-14ea0835cebe/

-- 
Thierry Carrez (ttx)