Subject: Re: sound on a thinkpad X23?




shadows writes:
> This is most likely your onboard or pcmcia NIC or the onboard modem. I am
> having the same problem with my Xircom 10-100TX +56k PCMCIA card. I am
> getting a new a one to replace it that is already tested with
> freebsd. With relation to the sound I saw on
> http://taylor.tam.uiuc.edu/~jfreund/Linux_Thinkpad_X23.html that he got it
> to work half ass. It may not work with freebsd at all.
>
> Thomas B
>
> On Wed, 27 Mar 2002, Dan Pelleg wrote:
>
> >
> > I'm having trouble configuring sound on a 2662-E5U. I'm getting nothing
> > under "Installed Devices" when I kldload snd. If I compile the kernel with
> > "device pcm", I get:
> >
> > pci0: <unknown card> (vendor=0x8086 dev=0x2483) at 31.3 irq 11
> > pcm0: <Intel 82801CA (ICH3)> irq 11 at device 31.5 on pci0
> > pcm0: unable to map IO port space
> > device_probe_and_attach: pcm0 attach returned 6
> >
> > Hints anyone?
> >
> >

Yeah, the pci0 message relates to the SMBus controller (if I'm reading the
output from pciconf correctly). I've got the onboard NIC and PCMCIA
wireless and the onboard modem (lucent winmodem via ltmdm port) to
work. Sound is the remaining issue...

I forgot to mention, I'm running 4.5R-p2. I'm attaching some pciconf
output that might give more info. And also CC-ing multimedia@ in hope of
more hints.

none1@pci0:31:5: class=0x040100 card=0x02221014 chip=0x24858086 rev=0x01
hdr=0x00
vendor = 'Intel Corporation'
device = '82801C...

A/CAM AC'97 Audio Controller'
class = multimedia
subclass = audio


--
Dan Pelleg

To Unsubscribe: send mail to majordomo@xxxxxxxxxxx
with "unsubscribe freebsd-mobile" in the body of the message





Privacy