Subject: Getting Maestro-3i to work in FreeBSD 4.5



Hey guys/girls,

Ok here goes. I have a Dell Lattitude CPxJ650GT with a builtin
Maestro-3i sound card. I was referencing the following information from
http://www.cs.duke.edu/~anderson/freebsd/maestro3xxx/ to get to where I am
now.

Add the following to your kernel config file:
device pcm0 at isa? irq 10 drq 1 flags 0x0 # for non-PnP sound cards
device pcm # for PnP/PCI sound cards

Then after doing that I believe during the boot sequence I got a message
stating to the fact that the driver cannot be loaded through the kernel
due to licensing restrictions and to add a line to my loader.conf which
was the following

snd_maestro3_load="YES"

Now when I do a cat /dev/sndstat instead of device not configured I get
the following.

# cat /dev/sndstat
FreeBSD Audio Driver (newpcm) Mar 25 2002 14:26:45
Installed devices:
pcm0: <ESS Technology Maestro3> at io 0xd800 irq 5 (1p/1r/0v channels
duplex)

But when I do startx with KDE I get the following message

Sound Server Informational Message

Error while initializing the sound driver
device /dev/desp can't be opened (Device not configured)

The sound server will continue, using the null output device

Ok well that sucks. So I popped up a shell and did cat /dev/dsp and cat
/dev/audio and both say Device not configured?

Can anyone tell me what exactly I did wrong if anything and possibly a
fix.

Would be most Appreciated

Thanks

Thomas B


To Unsubscribe: send mail to majordomo@xxxxxxxxxxx
with "unsubscribe freebsd-mobile" in the body of the message



...



Privacy