Subject: DFE-650 device timeout in 4.5-R



Hello.

It seems that each time I upgrade to a newever version of FreeBSD, my
D-Link DFE-650TX always has troubles. This time I've tried all the
previous remedies and I've had no luck. When I use 4.5-R and a GENERIC
kernel, the card is properly detected and resources allocated but the media
type is never initialized and of course the networking doesn't work (I get
the error: "ed1: device timeout"). In the past I've corrected this with
patches to the ed driver, which look to be in the 4.5 source, or I've
played with IRQs/PCCARD memory (which hasn't worked for a few versions),
and lately in the past year I've used the fa_select.c tool to initialize
the media connector. However in 4.5 I cannot get the connector properly
initialized using fa_select, nor does the kernel properly do so.. Any
suggestions? The MAC address is being read properly.

How come this is a constant problem with this card? I think it's a Rev C,
and back when I had the Rev A I never had troubles but i think it was a
different chipset. The mailing list archives seem to imply that the
problem has finally gone away, however my experience suggests otherwise.

Thanks in advance,

-- Rick C. Petty Senior Software Engineer, KIWI Computer
---------------------------------------------------------------
rick@xxxxxxxxxxxxxxxxx http://www.kiwi-computer.com/

To Unsubscribe: send mail to majordomo@xxxxxxxxxxx
with "unsubscribe freebsd-mobile" in the body of the message



...



Privacy